• Hola Visitante
  • Mostrar mensajes no leídos desde la última visita.
  • Mostrar nuevas respuestas a tus mensajes.

  • Autor Tema: Vlan id TV Orange  (Leído 15548 veces)

    0 Usuarios y 1 Visitante están viendo este tema.

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #90 en: 16 de Abril de 2018, 16:56:54 »
    Ya os iré contando...




    Enviado desde mi iPhone utilizando Tapatalk

    La Fibra

    Re:Vlan id TV Orange
    « Respuesta #90 en: 16 de Abril de 2018, 16:56:54 »

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #91 en: 19 de Abril de 2018, 17:23:59 »
    Diga lo que diga el servicio tecnico ... yo veo el trafico del iptv en la vlan 838

    y es lo que puse en la config

    /ip firewall filter
    add action=accept chain=input in-interface-list=orange_tv log=yes log-prefix=IGMP protocol=igmp
    add action=accept chain=forward dst-port=1234,1236 in-interface=vlan838 log=yes log-prefix="TV MULTICAST" out-interface=ether5-master-local protocol=udp src-address=92.58.250.160 src-port=1234
    add action=accept chain=input dst-port=1234 in-interface=vlan838 protocol=udp src-address=92.58.250.160 src-port=1234


    Todo correcto. Efectivamente no funcionaban canales como la FOX, he metido esas reglas excepto la primera y, a pesar de que no veo tráfico ni en la vlan838 ni en sendas reglas de firewall ahora los canales si que funcionan.


    Edito: Canales como la FOX se ven al instante y sin problema pero otros como AXN llegan a mostrar el mensaje de error de conexión y a los pocos segundos empieza a verse. Sin embargo, sigo sin ver tráfico en la vlan838 ni en las reglas de firmware. A pesar de eso sí que puedo confirmar lo de la vlan838 para clientes que tengan activada tv multicast.
    « Última modificación: 19 de Abril de 2018, 19:07:16 por ivimail »

    Desconectado vonsete

    • Recién llegado
    • *
    • Mensajes: 26
    • Karma: +1/-0
      • Ver Perfil
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #92 en: 19 de Abril de 2018, 22:30:42 »
    Pues no me cuadra ... solo dan ese STB a usuarios con conexion directa (nada de NEBA) y con fibra 300 y con IPTV

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #93 en: 20 de Abril de 2018, 01:02:57 »
    Yo soy directo pero ahora cuento la segunda parte de la película. Ya tenía una fibra de 300 con Orange en CTO de Vodafone y la nueva, también con Orange me la han conectado a CTO de Jazztel. Los parámetros en cualquier caso son los mismos, vlan cliente es la 832, conexión por dhcp...


    Como curiosidad, Orange está migrando todos los clientes a una velocidad superior, quedando descatalogada la fibra de 50 megas y quedando los 100 megas como oferta base. En mi caso, por tener 300 me tendrian que pasar a 500 megas, de hecho en la información comercial de mi cuenta ya salen los 500m pero aún sigo con 300, no se hasta cuando.

    Desconectado vonsete

    • Recién llegado
    • *
    • Mensajes: 26
    • Karma: +1/-0
      • Ver Perfil
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #94 en: 21 de Abril de 2018, 23:13:43 »
    La subida de velocidad sera gradual ... segun el ultimo speedtest que he hecho ya he visto que tengo el 500 simetrico  ;D ;D ;D ;D

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #95 en: 24 de Abril de 2018, 02:20:47 »
    Diga lo que diga el servicio tecnico ... yo veo el trafico del iptv en la vlan 838

    y es lo que puse en la config

    /ip firewall filter
    add action=accept chain=input in-interface-list=orange_tv log=yes log-prefix=IGMP protocol=igmp
    add action=accept chain=forward dst-port=1234,1236 in-interface=vlan838 log=yes log-prefix="TV MULTICAST" out-interface=ether5-master-local protocol=udp src-address=92.58.250.160 src-port=1234
    add action=accept chain=input dst-port=1234 in-interface=vlan838 protocol=udp src-address=92.58.250.160 src-port=1234


    Bueno, pues la iptv me funcionó el primer día y ya nunca más. Activando el IGMP snooping veo que sale la ip 232.48.190.66, será la de broadcast? habrá que meter alguna ruta en el firewall? a través de la vlan838 tan solo veo algún paquete suelto de vez en cuando pero no tráfico como tal.


    Canales que veo y canales que no:


    10 - no
    11 - no
    12 - no
    13 - no
    14 - no
    15 - no
    16 - si
    17 - si
    18 - no
    19 - no
    22 - no
    23 - si
    24 - si
    25 - si
    30 - no
    31 - si
    32 - primero no pero luego si
    33 - si
    34 - si
    35 - no
    36 - si
    37 - si
    38 - no
    39 - si
    42 - si
    43 - si
    44 - si
    45 - si
    46 - si
    47 - no
    50 - si
    51 - si
    52 - si
    53 - si
    55 - no
    56 - si
    57 - si
    58 - si
    59 - si
    60 - si
    61 - si
    62 - si
    63 - si
    64 - si
    65 - si
    66 - si
    67 - si
    68 - si
    76 - no
    77 - no
    78 - no
    Todos los Bein y la liga - no
    111 - si
    500 - no
    501 - si


    En los que no se ven me da el error L11-01


    « Última modificación: 24 de Abril de 2018, 03:36:28 por ivimail »

    Desconectado hcpizzi

    • Recién llegado
    • *
    • Mensajes: 2
    • Karma: +0/-0
      • Ver Perfil
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #96 en: 24 de Abril de 2018, 20:19:45 »
    Hola!

    Me he registrado en el foro porque gracias a este post y a otras mil cosas que he estado mirando durante la última semana he conseguido por fin jubilar el Livebox :) Os cuento lo que he hecho. Mi router es un Ubiquiti Unifi Security Gateway, así que si alguno tenéis un modelo de esta marca os puedo poner la configuración que tengo yo. Mi deco de la tele es el OHD80 con dongle USB.

    Definitivamente hacen falta las dos VLANs (832 y 838) en la conexión con el ONT (el mío es uno ZTE blanco). Creo que con la 832 no hay problemas por lo que veo, pero por si acaso, en esa hay un servidor DHCP, así que simplemente se configura como cliente DHCP, se hace el masquerade de la NAT y con eso deberíais tener internet y deberían funcionar los canales de TV que usan unicast, como Cosmo (no me juzguéis, me gusta masterchef :)).

    Para ver los canales que usan multicast hay que configurar la VLAN 838, el IGMP proxy, la NAT y el firewall. En la VLAN 838 no hay DHCP, pero en mi router al menos el IGMP proxy no funcionaba si la interfaz no tenía una IP asignada, así que le asigné una IP privada que no usaba en ninguna de las otras interfaces (192.168.10.1) y listo. Luego hay que habilitar el IGMP proxy, con la interfaz configurada sobre esta VLAN como upstream (en mi caso es eth0.838) y en la que tengáis el deco de la tele como downstream. Después, para que esto funcione, también hay que configurar el NAT para que haga masquerade de la interfaz LAN a eth0.838. Y por último tuve que añadir una regla al firewall para permitir la entrada (FORWARD en iptables) de paquetes UDP con destino a las IP de multicast (224.0.0.0/4). Esto sería más seguro si conociera las IPs que usa orange para el multicast, pero de momento lo tengo así. También creé otra para aceptar los paquetes del protocolo IGMP dirigidos al router, pero parecía que todo funcionaba bien sin esa. De momento la he dejado, pero ahora que ya tengo algo que funciona experimentaré un poco más.

    Aún hay algún problemilla. Por ejemplo, se nota que algunos de los paquetes UDP se pierden, sobre todo si hago un test de velocidad con fast.com y de repente la linea se satura. Que por cierto, esta mañana vi que la velocidad era 100 mbps en lugar de 50 y pensaba que sería que el Livebox reservaba una burrada de ancho de banda para la tele, pero ya he leído que es que han aumentado las velocidades  ;D

    Voy a seguir investigando, porque he viso alguna gente que ha hecho un bridge entre la interfaz de la VLAN 838 y a la que tienen conectado el deco, pero de momento ya he gastado mucho tiempo en esto y ahora quiero ponerme con la razón por la que quería cambiar el router: montar una VPN para poder acceder por escritorio remoto a mi ordenador :)

    Espero que esto os ayude. Si tenéis alguna duda a ver si os la puedo resolver.
    « Última modificación: 24 de Abril de 2018, 20:22:38 por hcpizzi »

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #97 en: Ayer a las 01:03:56 »
    Pues aquí ando ahora con un EdgeRouter Lite 3 haciendo mis pruebas para la iptv por una de las dos fibras asi que voy a tomar algunas notas de lo que has puesto a ver si consigo sacar algo en claro.


    Edit: @hcpizzi pongo la config completa para que me la eches un vistazo, no doy con la tecla y creo que algo estoy metiendo mal en las reglas de firewall o el nat a la eth0.838


    La wan es la eth0.832, la vlan para iptv es eth0.838 y la lan del deco es la eth2 con rango 192.168.2.1/24. La ip dummy de la vlan838 es la 192.168.10.1/24


    Código: [Seleccionar]
    admin@ubnt:~$ show configuration
    firewall {
        all-ping enable
        broadcast-ping disable
        ipv6-receive-redirects disable
        ipv6-src-route disable
        ip-src-route disable
        log-martians enable
        name WAN_IN {
            default-action drop
            description "WAN to internal"
            rule 10 {
                action accept
                description "Allow established/related"
                state {
                    established enable
                    related enable
                }
            }
            rule 20 {
                action accept
                description IPTV
                destination {
                    address 192.168.10.0/24
                }
                log disable
                protocol udp
                source {
                    address 224.0.0.0/4
                }
                state {
                    established enable
                    invalid enable
                    new enable
                    related enable
                }
            }
            rule 30 {
                action accept
                description igmp
                destination {
                    address 192.168.10.0/24
                }
                log disable
                protocol igmp
                source {
                    address 224.0.0.0/4
                }
                state {
                    established enable
                    invalid enable
                    new enable
                    related enable
                }
            }
            rule 40 {
                action drop
                description "Drop invalid state"
                state {
                    invalid enable
                }
            }
        }
        name WAN_LOCAL {
            default-action drop
            description "WAN to router"
            rule 10 {
                action accept
                description "Allow established/related"
                state {
                    established enable
                    related enable
                }
            }
            rule 20 {
                action drop
                description "Drop invalid state"
                state {
                    invalid enable
                }
            }
        }
        receive-redirects disable
        send-redirects enable
        source-validation disable
        syn-cookies enable
    }
    interfaces {
        ethernet eth0 {
            duplex auto
            speed auto
            vif 832 {
                address dhcp
                description Internet
                firewall {
                    in {
                        name WAN_IN
                    }
                    local {
                        name WAN_LOCAL
                    }
                }
                ip {
                    enable-proxy-arp
                }
            }
            vif 838 {
                address 192.168.10.1/24
                ip {
                    enable-proxy-arp
                }
            }
        }
        ethernet eth1 {
            address 192.168.0.62/24
            description Local
            duplex auto
            speed auto
        }
        ethernet eth2 {
            address 192.168.2.1/24
            description "Local 2"
            duplex auto
            speed auto
        }
        loopback lo {
        }
    }
    protocols {
        igmp-proxy {
            interface eth0.838 {
                alt-subnet 192.168.2.0/24
                role upstream
                threshold 1
            }
            interface eth2 {
                alt-subnet 192.168.2.0/24
                role downstream
            }
        }
    }
    service {
        dhcp-server {
            disabled false
            hostfile-update disable
            shared-network-name LAN2 {
                authoritative enable
                subnet 192.168.2.0/24 {
                    default-router 192.168.2.1
                    dns-server 192.168.2.1
                    lease 86400
                    start 192.168.2.38 {
                        stop 192.168.2.243
                    }
                }
            }
            static-arp disable
            use-dnsmasq disable
        }
        dns {
            forwarding {
                cache-size 150
                listen-on eth1
                listen-on eth2
            }
        }
        gui {
            http-port 80
            https-port 443
            older-ciphers enable
        }
        nat {
            rule 5010 {
                description "masquerade for WAN"
                outbound-interface eth0.832
                type masquerade
            }
            rule 5011 {
                description "masquerade for WAN"
                destination {
                    group {
                    }
                }
                log disable
                outbound-interface eth2
                protocol all
                source {
                    group {
                    }
                }
                type masquerade
            }
        }
        ssh {
            port 22
            protocol-version v2
        }
        upnp {
            listen-on eth1 {
                outbound-interface eth0.832
            }
            listen-on eth2 {
                outbound-interface eth0.832
            }
        }
    }
    system {
        host-name ubnt
        login {
            user admin {
                authentication {
                    encrypted-password ****************
                }
                level admin
            }
        }
        ntp {
            server 0.ubnt.pool.ntp.org {
            }
            server 1.ubnt.pool.ntp.org {
            }
            server 2.ubnt.pool.ntp.org {
            }
            server 3.ubnt.pool.ntp.org {
            }
        }
        offload {
            hwnat disable
            ipsec enable
            ipv4 {
                forwarding enable
                gre enable
                pppoe enable
                vlan enable
            }
            ipv6 {
                forwarding enable
                pppoe disable
            }
        }
        syslog {
            global {
                facility all {
                    level notice
                }
                facility protocols {
                    level debug
                }
            }
        }
        time-zone UTC
        traffic-analysis {
            dpi enable
            export enable
        }
    }
    admin@ubnt:~$
    « Última modificación: Ayer a las 01:38:35 por ivimail »

    Desconectado hcpizzi

    • Recién llegado
    • *
    • Mensajes: 2
    • Karma: +0/-0
      • Ver Perfil
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #98 en: Ayer a las 07:07:28 »
    Veo que las reglas del firewall están mal. En la de WAN_IN, que es sin la cual no funciona, 224.0.0.0/0 es el destino, no el origen. Aquí esta la mía en formato JSON:

    Código: [Seleccionar]
    "2001": {
            "action": "accept",
            "destination": {
                    "address": "224.0.0.0/4"
            },
            "protocol": "udp"
    }

    La del protocolo IGMP la tengo en WAN_LOCAL. Esa es la que parecía que no era necesaria. Aun así, esta es la mía:

    Código: [Seleccionar]
    "2001": {
            "action": "accept",
            "destination": {
                    "address": "224.0.0.0/4"
            },
            "protocol": "igmp"
    }

    Yo las tengo puestas antes que las de por defecto, pero no comprobé que estuviese tirando paquetes por alguna de las otras dos reglas que vienen por defecto. En cualquier caso lo que voy a hacer es crear reglas nuevas solo para eth0.838 por seguridad, al menos hasta que sepa las IPs de origen de los streams de orange. En cualquier caso a ti te falta también declarar las reglas de firewall para la interfaz eth0.838. No sé si por defecto eso significa dejar pasar todo o no dejar pasar nada, así que mejor meterlas:

    Código: [Seleccionar]
    "838": {
            "address": [
                    "192.168.10.1/24"
            ],
            "firewall": {
                    "in": {
                            "ipv6-name": "WANv6_IN",
                            "name": "WAN_IN"
                    },
                    "local": {
                            "ipv6-name": "WANv6_LOCAL",
                            "name": "WAN_LOCAL"
                    },
                    "out": {
                            "ipv6-name": "WANv6_OUT",
                            "name": "WAN_OUT"
                    }
            }
    }

    Luego, en el IGMP proxy, tengo un alt-subnet de 0.0.0.0/0 en el upstream para que admita paquetes provenientes de cualquier IP. De nuevo, no he probado a quitarlo y ver qué pasa, tengo que jugar un poco más para quedarme con lo estrictamente necesario. Esta es mi configuración:

    Código: [Seleccionar]
    "igmp-proxy": {
            "interface": {
                    "eth0": {
                            "role": "disabled",
                            "threshold": "1"
                    },
                    "eth0.832": {
                            "role": "disabled",
                            "threshold": "1"
                    },
                    "eth0.838": {
                            "alt-subnet": [
                                    "0.0.0.0/0"
                            ],
                            "role": "upstream",
                            "threshold": "1"
                    },
                    "eth1": {
                            "role": "disabled",
                            "threshold": "1"
                    },
                    "eth2": {
                            "role": "downstream",
                            "threshold": "1"
                    }
            }
    }

    Y por último falta la regla del NAT para et0.838. Sin ella el IGMP proxy envía los mensajes de IGMP con la IP del host (192.168.2.x). Esta es mi regla.

    Código: [Seleccionar]
    "6010": {
            "description": "MASQ corporate_network to WAN",
            "log": "disable",
            "outbound-interface": "eth0.838",
            "protocol": "all",
            "source": {
                    "group": {
                            "network-group": "corporate_network"
                    }
            },
            "type": "masquerade"
    }

    Eso es básicamente todo lo que tengo cambiado. A ver si te funciona!

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #99 en: Ayer a las 16:02:52 »
    Nada, he estado haciendo el tonto porque sobre una de las fibras no tengo activada la tv multicast así que solo me queda hacerla funcionar sobre la otra fibra con el mikrotik. Gracias de todas formas.

    Desconectado ivimail

    • Administrador
    • Experto en el foro
    • *****
    • Mensajes: 417
    • Karma: +10/-0
      • Ver Perfil
      • HispaHosted
    • Operador: Orange
    Re:Vlan id TV Orange
    « Respuesta #100 en: Ayer a las 17:26:27 »
    Venga, que vamos a flipar un poco con la solución a lo de la iptv en el mikrotik. En el CCR la configuración de los puertos que tengo actualmente son eth1-4 en un bridge (desde v.6.41) y en el puerto 7 la ont, con las vlan 832 y 838.

    Tan solo he añadido la interfaz 838 al bridge y voila!! iptv funcionando.

    Funciona tanto con igmp proxy activado o desactivado en el bridge, no hace falta meter reglas en el firewall ni en el igm-proxy ni nada de nada. Es más, ni tan siquiera hay que hacer un masquerado a la vlan838 en nat. Absolutamente nada de nada.



    Disfrutadlo.


    Edito: problemas que me he encontrado a posteriori.


    Ojo con el igmp snooping si tenéis switches gestionables en la red. Tras probar directamente al router el receptor y comprobar que la tv efectivamente funcionaba me he encontrado que, tras enchufarlo en otra parte no funcionaba. En este caso son un CSS326-24G-2S+ con SwOS 2.7 y un CRS125-24G-1S con RouterOS 6.42.1, por alguna oscura razón no termina de ir fina la tv, al cambiar de canal llega a aparece el mensaje de error de recepción y al rato empieza a funcionar. Además el CSS326 se atasca con la interfaz web, me decanto por pensar que es algún problema en esa versión de SwOS.
    « Última modificación: Ayer a las 17:51:23 por ivimail »

    La Fibra

    Re:Vlan id TV Orange
    « Respuesta #100 en: Ayer a las 17:26:27 »